[uplug] WLAN Check

Jonas Hörsch jonas at chaoflow.net
Fr Mär 18 12:23:10 CET 2016


Hallo Hartmut,

ich habe lange ein sehr ähnliches Problem in einem FritzBox verwalteten
HomeLan gehabt. Es gab grob folgende Symptome:
- Manchmal hat alles normal funktioniert
- Manchmal habe ich lange keine IP gekriegt. Erst nach einem manuellen
  hard-block und wieder unblocken. Konnte ich mich wieder verbinden.
- Manchmal hatte ich nach einer Zeit halbwegs periodisch auftretende
  Muster von guter Konnektivität mit hohem Datendurchsatz für eine
  Minute und dann einem quasi-Abbruch begleitet von vielen ARP Paketen
  zwischen Router und Rechner die sich gegenseitig nicht sahen. Ein
  parallel mitlaufender Ping ging runter auf die standardmäßigen
  ms-Werte und dann ein halbe Minute später wieder zu lost packages oder
  sec lange Latenzzeiten. Häufig dann kurze Zeit später wieder normal.
  Wenn das auftrat ist der Rechner auch nicht mehr in der Liste der
  angemeldeten Rechner der fritz box verwaltungsoberfläche aufgetaucht.

Auf anderen Rechnern im WLAN ist das Problem nie so aufgetreten, ich bin
aber auch der einzige Linux-Nutzer. Ausserdem habe ich dem Pattern
selbst nicht so recht geglaubt. Kanäle habe ich mehrmals manuell
geändert nie mit einem klaren Erfolg. Das Pattern war auch ein bisschen
zu random um es ordentlich zu debuggen und ich wusste nicht so recht wo
anzusetzen sei.

Ich habe jetzt vor einer Woche den dhcp client meiner Debian
(unstable)-Installation von dem Standard isc-dhcp-client (dhclient) auf
den network manager internen gestellt. das Problem ist noch nicht
wieder aufgetreten und ich hoffe dass das so bleibt.

Lange Rede kurzer Sinn, ich habe KEINE Erklärung, aber du könntest
vielleicht auch mal probieren einen anderen dhcp clienten zu verwenden.
(mit network manager bedeutet das einen neuen Eintrag
dhcp=internal in die main section von
/etc/NetworkManager/NetworkManager.conf zu schreiben und network manager
neu zu laden)

Lg,
Jonas


On Thu, Mar 17 2016, Hartmut Phieler wrote:

> Hallo Andreas,
>
> ich habe deine Antwort mal als Vorlage für mein Untersuchungsmuster
> verwendet. Neben deinen Empfehlungen hatte ich auch schon ein paar Dinge
> anderweitig geprüft.
>
> Am 17.03.2016 um 01:02 schrieb Alexander Schultz:
>> Hallo Harry,
>>
>> - lade irgendeine bekannte und aktuelle Linux iso-Datei per Bittorrent,
>> und schaue wie sich die Download-Raten bei Lan und Wlan unterscheiden
> Habe gerade mal ein Image geladen. Die Übertragung per LAN lag bei ~800
> kB/s und im WLAN etwa 50 bis 100 kB/s niedriger, also in einem Bereich,
> der meiner Ansicht nach fast noch unter die Kategorie statistisches
> Rauschen fällt. Wenn, dann war die Geschwindigkeit im Torrent nur
> marginal schlechter.
>
> Das Problem scheint auch zu sein, dass es spikes bei der Qualität gibt,
> also Momente, in denen minutenweise die Verbindung selbst zum Surfen zu
> lahm ist, während es zu anderen Zeiten flüssig läuft. Diese spikes sind
> mir bisher nicht im LAN aufgefallen (nutze ich aber hier auch
> normalerweise nicht).
>
>>
>> - lade jemand mit einem anderen Laptop zu dir ein und teste, ob er die
>> gleichen Unterschiede feststellt
> Zu deiner Info: Im WLAN können sich zeitweise bis zu 6 Laptops
> aufhalten, zur Zeit sind eher weniger. Mit anderen konnte ich es noch
> nicht testen, doch über die Unterbrechungen / miese Qualität beschweren
> sich alle (mit unterschiedlicher Nähe zum Router). Ich bin momentan auch
> der einzige Linux-Nutzer (Dual Boot) im Netz, das WLAN wird von Windows
> und ein paar Macs bevölkert.
> Probleme treten bei mir in Win als auch Linux auf.
>
>>
>> - ich nehme an, du nutzt Debian, scanne nach Wlan-Netzen im Terminal per
>> "iwlist wlan0 scan" (mit root-Rechten, ersetze wlan0 ggf. mit deinem
>> Interface. Achte bei der Ausgabe auf Quality und Signal level -
>> vergleiche die Daten mit den Netzen der Nachbarn. Und "cat
>> /proc/net/wireless" (gibt auch den Namen des Interface an)
> Jup, ich nutze Debain als Arbeitssystem. Wenn ich im Raum mit dem Router
> bin (wo übrigens auch die bekannten Probleme auftreten), liegt die
> Qualität bei 60/70 und das Signal Level bei gut -50dBm
> Der Router ist idR auch der stärkste Sender in der Umgebung. Die anderen
> Netze liegen bei einer Qualität mit gut 30 Punkten drunter und einem
> Level von -60 bis -90dBm.
> Der Vergleich mit cat /proc/net/wireless ergibt erstmal nahezu
> identische Werte= 60 und -50
>  
>>
>> - Schaue auf welchem Kanal die benachbarten Router funken, und stelle
>> deinen Kanal im Router auf 1,6 oder 11 (auf denjenigen von den Dreien,
>> der am wenigsten verwendet wird)
> Die Oberfläche vom Router hat eine brauchbare grafische Oberfläche, in
> der nicht nur benachbarte Netze und Kanäle angezeigt werden, sondern
> auch der Lärmpegel angezeigt werden kann (der scheint über alle Kanäle
> verteilt sehr hoch zu sein, war das aber schon immer).
>
> Ich habe den Router und den Repeater übrigens auf Kanal 13 eingestellt.
> Kanal 1 ist völlig überfüllt und Kanal 6 wirkt aus Routerperspektive
> zwar halbwegs gut, in Repeaternähe ist er auch völlig zu. Beste Option
> schein mir der höhere Bereich zu sein, zumal die wenigsten Kanal 13
> nutzen (können). Durch Verwendung eines Repeaters ist der Kanal nicht
> dynamisch sondern fest auf 13.
>
>
>
> Wie bereits erwähnt, ist das Problem erst kürzlich und massiv
> aufgetreten. Vorher hat alles relativ gut funktioniert ohne die krassen
> Ausfälle. Das WLAN in der Umgebung ist meiner Erfahrung nach stark
> überfrachtet, weil fast jede Wohnung / jedes Büro in der Umgebung nen
> Router zu haben scheint. Das fiel bisher aber nicht so auf. Allerdings
> glaube ich auch nicht, dass in so einer Situation ein einzelner neuer
> Sender das Netz so stören sollte, zumal mir keinen neuen Netze im
> Bereich 11-13 aufgefallen sind.
>
> Fallen dir neben üblicheren Störquellen im WLAN noch andere Dinge ein,
> die es zu prüfen lohnt?
>
> LG
> Harry
>
> _______________________________________________
> upLUG mailing list
> upLUG at lists.astaup.de
> http://lists.astaup.de/listinfo/uplug
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname   : signature.asc
Dateityp    : application/pgp-signature
Dateigröße  : 818 bytes
Beschreibung: nicht verfügbar
URL         : <http://lists.astaup.de/pipermail/uplug/attachments/20160318/bfea6db3/attachment-0001.sig>


Mehr Informationen über die Mailingliste upLUG