[uplug] Re: bootproblem - grub

zscherni at arcor.de zscherni at arcor.de
Sa Feb 8 15:04:01 CET 2014


Hallo.

> Auch ich würde Dir primär zu einem aktuellen Linux raten! OpenSuse ist
> inzwischen bei 13.2 glaub ich.

Ich habe bestimmt schon drei neuere Suses ausprobeirt (11.2, 11.3, 12.1 glaub ich), aber das war für mich alles inakzeptabel. Da kann man nicht mehr vernünftig pdfs drucken, weil das neue kde keine ausgereifte Druckkomponente mitbringt, kcontrol gibts auch nicht mehr, das neue gnome funktioniert nicht mehr so, wie ich das erwarte und möchte (Menü-Taste bzw. rechter Mausklick) und und und 
Kurz und gut - die paar Probleme, die ich bei 10.3 habe nehme ich lieber in Kauf, als die vielen neuen.
(Auf meinem Server habe ich eine neues Linux, aber eingespielte Sachen wie DVDs brennen, drucken, scannen etc. laufen auf meinem laptop unter suse 10.3 und NEVER CHANGE A RUNNING SYSTEM. Dachte ich - weshalb ich es kopieren wollte...)

> Falls Dir das zuviel sein sollte mit nem
> Distributionsupgrade, dann wäre vllt eine "Rolling-Release"
> Distribution besser für dich. Da fällt mir spontan Debian unstable ein.
> Da brauchst du nur immer mal Updates machen und damit hat sichs.
> 
> Ansonsten falls du wirklich auf deinem System bleiben willst, dann
> versuchs mal mit:
>   grub-install /dev/sda
> Damit sollte alles wieder funzen...
> 
> Falls es nicht den gewünschten Erfolg bringt, dann poste hier bitte die
> Fehlermeldungen! ;)

Also hier mal das, was ich tat.

Kanotix:/# mkdir /mnt/sda2
Kanotix:/# mount /dev/sda2 /mnt/sda2/
Kanotix:/# mount -o bind /dev /mnt/sda2/dev/
Kanotix:/# mount -t proc proc /mnt/sda2/proc/
Kanotix:/# chroot /mnt/sda2/ /bin/bash
Kanotix:/# grub-install /dev/sda

    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename. ]
grub> setup --stage2=/boot/grub/stage2 (hd0,1) (hd0,1)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0,1)"... failed (this is not fatal)
 Running "embed /boot/grub/e2fs_stage1_5 (hd0,1)"... failed (this is not fatal)
 Running "install --stage2=/boot/grub/stage2 /boot/grub/stage1 (hd0,1) /boot/grub/stage2 p /boot/grub/menu.lst "... succeeded
Done.
grub> quit

Wie gesagt kommt nach einem Neustart nur 

GRUB GRUB

und nichts weiter (keine Grub-Befehlszeile)

Vorher startete tatsächlich erst die (nicht mehr existente) menu.lst von sda3 (wo ich die neueren linuces ausprobierte), in der ich das System auf sda2 eingetragen und als default gesetzt hatte, so dass ich nacheinander zwei Grub-Bootmenüs bekam.

Nun geht leider erstmal nichts mehr.

Könnte wahrscheinlich wieder ein neues linux auf sda3 neu-installieren, um das Problem zu lösen, aber dann hätte ich eben keine Kopie meines Arbeitssystems.

VG

Sebastian




Mehr Informationen über die Mailingliste upLUG