[uplug] Probleme mit fsck

Bernd Nemetz berndnemetz at bn.in-berlin.de
Mi Mai 17 11:50:16 CEST 2006


Hallo Jan

das erinnert mich an ein Problem was ich vor einiger Zeit hatte. Die  
selben Symptome, aber jetzt kommt's der Fehler war eine def. 500'er  
Speicherbank.
Der Fehler war reproduzierbar. Speicher raus System rannte ohne  
Probleme, Speicher rein Chaos nicht alle Filesysteme gefunden,  
Abstürze, keine Grafik usw.
Das muss jetzt bei dir  nicht das selbe sein, aber ich habe ewig  
gesucht bis ich das gefunden hatte :-( Mit def. Speicher bei  
"Festplattenproblemen" hatte ich nun überhaupt nicht gerechnet. Mach  
doch mal prophylaktisch, wie die Zahnärzte immer sagen einen  
Speichertest :-))


Gruß Bernd


Am 11.05.2006 um 14:36 schrieb heidbr at rz.uni-potsdam.de:

> Hi!
>
> Ich habe folgendes seltsame Problem mit fsck für ext2:
>
> Nach einem Absturz wurden Fehler auf /dev/hda5 (mountpoint /home)  
> gefunden, fsck
> wird beim Booten gestartet um die Fehler zu beheben, folgendes wird  
> ausgegeben
> (zum Beispiel, die betroffenen Dateien sind jedesmal andere):
>
> --------------------------------------------------------
> [/sbin/fsck.ext2 (1) -- /home] fsck.ext2 -a -C0 /dev/hda5
> /dev/hda5 contains a file system with errors, check forced.
> /dev/hda5: Duplicate or bad block in use!
> /dev/hda5: Multiply-claimed block(s) in inode 1893125: 688765
> /dev/hda5: Multiply-claimed block(s) in inode 1958406: 5005437
> /dev/hda5: (There are 2 inodes containing multiply-claimed blocks.)
>
> /dev/hda5: File /suppe/.aMule/Temp/005.part (inode #1893125, mod  
> time Thu Apr
> 20
>  01:09:27 2006)
>   has 1 multiply-claimed block(s), shared with 0 file(s):
> /dev/hda5: Multiply-claimed blocks already reassigned or cloned.
>
> /dev/hda5: File /suppe/download/from-amule/Bach 2000 Teldec-Vol 11  
> Cd 11-Flute
> S
> onatas & Canons Bwv1013,1031,1033,1072-8,1080,1086.zip (inode  
> #1958406, mod
> time
>  Mon Mar 13 15:36:01 2006)
>   has 1 multiply-claimed block(s), shared with 0 file(s):
> /dev/hda5: Multiply-claimed blocks already reassigned or cloned.
> ---------------------------------------------------------
>
> Wenn der Statusbalken 95% erreicht hat, passiert nichts mehr, außer  
> das er immer
> auf 95.1% und wieder zurück springt. Das geht dann ewig bis ich mit  
> Strg+C
> abbreche. Rufe ich fsck manuell auf, findet er irgendwann "bitmap  
> block
> differences" und fragt mich ob er diese beheben soll. Antworte ich  
> mit Yes
> findet er stets weitere und das geht dann auch ewig so weiter.
>
> Zudem stürzt mein System seitdem häufig und gerne ab (nicht komplett,
> ssh-Zugriff wäre möglich wenn ich einen zweiten Rechner hätte, aber  
> er reagiert
> nicht mehr auf Maus+Tastatur und auch xmms spielt nicht mehr).
>
> Ich frage mich natürlich wo ich den Fehler suchen soll, bei fsck  
> oder einfach
> bei der Festplatte.. Ich hab' mit dem IBM Drive Fitness Test einen  
> check
> gemacht bzw. in meiner Abwesenheit einen check machen lassen, als  
> ich wieder
> kam wurden allerdings weder Fehler angezeigt noch gemeldet daß es  
> keinen Fehler
> gab, die einzige Meldung lautete in etwa "Test beendet".
>
> Vielleicht hat ja jemand eine Idee, wie man die Ursache dieses  
> Verhaltens
> herausfinden kann, mit Google hab' ich leider niemanden gefunden,  
> der das
> gleiche Problem schonmal hatte.
>
> Grüße, Jan
> _______________________________________________
> upLUG mailing list
> upLUG at uplug.de
> https://mail.asta.uni-potsdam.de/mailman/listinfo/uplug




Mehr Informationen über die Mailingliste upLUG