[uplug] Probleme mit fsck

Timo Felbinger csmchh-jupp at 19.05.2006.best-before.qipc.org
Do Mai 11 18:10:19 CEST 2006


On Thu, May 11, 2006 at 02:36:56PM +0200, heidbr at rz.uni-potsdam.de wrote:
> 
> Hi!
> 
> Ich habe folgendes seltsame Problem mit fsck f?r ext2:
> 
> Nach einem Absturz wurden Fehler auf /dev/hda5 (mountpoint /home) gefunden, fsck
> wird beim Booten gestartet um die Fehler zu beheben, folgendes wird ausgegeben
> (zum Beispiel, die betroffenen Dateien sind jedesmal andere):
> 
> --------------------------------------------------------
> [/sbin/fsck.ext2 (1) -- /home] fsck.ext2 -a -C0 /dev/hda5 
> /dev/hda5 contains a file system with errors, check forced.
> /dev/hda5: Duplicate or bad block in use!
> /dev/hda5: Multiply-claimed block(s) in inode 1893125: 688765
> /dev/hda5: Multiply-claimed block(s) in inode 1958406: 5005437
> /dev/hda5: (There are 2 inodes containing multiply-claimed blocks.)
> 
> /dev/hda5: File /suppe/.aMule/Temp/005.part (inode #1893125, mod time Thu Apr
> 20
>  01:09:27 2006) 
>   has 1 multiply-claimed block(s), shared with 0 file(s):
> /dev/hda5: Multiply-claimed blocks already reassigned or cloned.
> 
> /dev/hda5: File /suppe/download/from-amule/Bach 2000 Teldec-Vol 11 Cd 11-Flute
> S
> onatas & Canons Bwv1013,1031,1033,1072-8,1080,1086.zip (inode #1958406, mod
> time
>  Mon Mar 13 15:36:01 2006) 
>   has 1 multiply-claimed block(s), shared with 0 file(s):
> /dev/hda5: Multiply-claimed blocks already reassigned or cloned.
> ---------------------------------------------------------
> 
> Wenn der Statusbalken 95% erreicht hat, passiert nichts mehr, au?er das er immer
> auf 95.1% und wieder zur?ck springt. Das geht dann ewig bis ich mit Strg+C
> abbreche. Rufe ich fsck manuell auf, findet er irgendwann "bitmap block
> differences" und fragt mich ob er diese beheben soll. Antworte ich mit Yes
> findet er stets weitere und das geht dann auch ewig so weiter.
> 
> Zudem st?rzt mein System seitdem h?ufig und gerne ab (nicht komplett,
> ssh-Zugriff w?re m?glich wenn ich einen zweiten Rechner h?tte, aber er reagiert
> nicht mehr auf Maus+Tastatur und auch xmms spielt nicht mehr).
> 
> Ich frage mich nat?rlich wo ich den Fehler suchen soll, bei fsck oder einfach
> bei der Festplatte.. Ich hab' mit dem IBM Drive Fitness Test einen check
> gemacht bzw. in meiner Abwesenheit einen check machen lassen, als ich wieder
> kam wurden allerdings weder Fehler angezeigt noch gemeldet da? es keinen Fehler
> gab, die einzige Meldung lautete in etwa "Test beendet".

Nur ein paar Ideen:

- Findet sich im System-Log (/var/log/messages) irgendwas, was die Festplatte
betrifft? hard/soft read/write errors, insbesondere? Wenn die Platte langsam
vor sich hin stirbt, koennen alle moeglichen Fehler auftreten.

- Die betroffene Partition/Filesystem hast Du nicht mir zufaellig mal
mit einem Program veraendert (z.B. verkleinert), das das nicht wirklich
kann?

- Dein Kernel ist nicht zufaellig ein "frueher" 2.6-er?
Mit 2.6.x fuer x < 8 hatte ich auch oefters mal komplett zerschossene
ext2/3-Filesysteme, seitdem nicht mehr (muss offenbar ein echter Bug
gewesen sein).

- Im uebrigen wuerde ich die Platte erstmal read-only mounten und
versuchen, noch ein Backup zu machen (aber das hast Du eh schon
gemacht, oder????).
Und wenn danach fsck nicht sauber durchlaeuft (oder mehr als eine
kleine Handvoll Fehler meldet): mkfs und Backup zurueckspielen.
Ist die schnellste und sauberste Loesung.

Viele Gruesse,

Timo




Mehr Informationen über die Mailingliste upLUG