[uplug] Xmodmap und unicode

Sebastian Zschernig zscherni at rz.uni-potsdam.de
Fr Jul 8 21:42:25 CEST 2005


Leider werde ich nicht da sein, wenn es in zwei Wochen um unicode geht.

Und nun habe ich gerade ein Problem.

Habe mir eine Xmodmap gebastelt, um diverse Zeichen aus dem unicode-
(eigentlich erstmal nur latin-1/ iso-8859-1 UND latin-2/ iso-8859-2 was
sich ja schonmal nicht verträgt) Vorrat direkt eingeben zu können.

Habe außerdem auf utf-8 (de-DE-utf8 oder so ähnlich) als
System-Standard umgestellt.

(Nun tritt zunächst schon ein kleines Problem auf: das terminal
(gnome-terminal (suse9.0)) meint immernoch iso-8859-1 sei die aktuelle
Standorteinstellung, mit der es zu öffnen habe.)

Aber zum eigentlichen Problem:
Wenn ich (terminal auf utf-8 gestellt) dead_cedilla (bei mir nun
AltGr+accent-Taste) und dann s drücke erhalte ich wie gewünscht s mit
cedilla (unicode 0219), wenn ich das gleiche aber mit t probiere piept
der Rechner nur boshaft statt unicode 021B anzuzeigen.

Mit OpenOffice (1.1.0) wird das ganze noch "lustiger":
weder s noch t mit cedilla kann ich eingeben (c hingegen schon) und
dabei wollte ich gerade hier vermeiden immer über
Einfügen-Sonderzeichen gehen zu müssen!

Das nervt doch.

Hat jemand hilfreiche Tips/ Ideen?

Viele Grüße

Sebastian


PS:
Kann mir eigentlich jemand sagen, was die dritte und vierte Spalte in
der Xmodmap-Datei bedeuten? (erste: nur Taste, zweite: Umschalt+Taste,
fünfte AltGr+Taste, sechste: AltGr+Umschalt+Taste)
Komisch auch, dass man anscheinend dem n (keycode 57) überhaupt keine
weiteren Funktionen (dritte bis sechste Spalte der Xmodmap-Datei werden
ignoriert) zuweisen kann.



Mehr Informationen über die Mailingliste upLUG